Message info
 
To:Arch User Repository (AUR) Development From:Stefan Husmann Subject:Re: [aur-dev] pdftk unusable Date:Thu, 22 Mar 2012 20:25:55 +0100
 

Am 22.03.2012 19:17, schrieb tt@bu.edu:
> I have errors from pdftk, and the pdf files that come out are unusable.
> Any suggestions, or links to a usable pdftk source or monolithic bynary?
> Thanks,
> Tommaso Toffoli
>
>
> I just installed the pdftk 1.44-5 (AUR package) in a freshly installed Arch
> Linux 64-bit system. I installed this package first manually, directly from
> AUR, and a second time using Yaourt, with exactly the same results.
> [I had used pdftk on the previous install (a couple of months ago) of Arch
> Linux on the same machine, and that had been working without any
> problems. Also, the latter installed instantly, while the new one had to go
> through half an hour of an enormous gcc-gcj installation.]
>
> Nature of the problem
>
> When I run pdftk I get the following messages:
>
> tt@pks:~/beazwork$ pdftk body.pdf cat 645 output page.pdf
> Unhandled Java Exception:
> Unhandled Java Exception:
> java.lang.NullPointerException
> at gnu.gcj.runtime.NameFinder.lookup(libgcj.so.12)
> at java.lang.Throwable.getStackTrace(libgcj.so.12)
> at java.lang.Throwable.stackTraceString(libgcj.so.12)
> at java.lang.Throwable.printStackTrace(libgcj.so.12)
> at java.lang.Throwable.printStackTrace(libgcj.so.12)
>
> When I play back the resulting file, I get the following messages:
>
> tt@pks:~/beazwork$ xpdf page.pdf
> Warning: Cannot convert string "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string "-*-courier-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string "-*-times-bold-i-normal--20-*-*-*-*-*-iso8859-1" to type FontStruct
> Warning: Cannot convert string "-*-times-medium-r-normal--14-*-*-*-*-*-iso8859-1" to type FontStruct
> Syntax Error: Couldn't read xref table
> Syntax Warning: PDF file is damaged - attempting to reconstruct xref table...
> Syntax Error: Couldn't find trailer dictionary
> Syntax Error: Couldn't read xref table
>
> Questions
>
> -- The gcc version currently supplied by Arch Linux is gcc 4.6.3.
> Mine is a 64-bit system; could it be an issue of 32 vs 64 bits?
no
> -- Is there a simpler, perhaps older, monolithic binary that I can use in the
> interim?
there is pdftk-bin in AUR.
> -- Any hope I could be running pdftk again any time soon?
Works fine here.

You are on the wrong list. This list is for AUR developement. aur-general or the forum would be correct.


Regards Stefan