Message info
 
To:Fossil SCM user\'s discussion From:Matt Welland Subject:Re: [fossil-users] SSH commands run as user nobody Date:Mon, 7 May 2012 13:37:39 -0700
 

Regarding ssh transport for fossil: I've been trying to get ssh to work with fsecure and on Linux (openssh) and I have never had any luck. If someone using fossil ssh for clone, sync etc. with different user(s) or different hosts at either end of the pipe could post their exact setup and settings I will try again as I really need this to work.

On Mon, May 7, 2012 at 1:29 PM, Timothy Beyer <beyert@fastmail.net> wrote:
At Mon, 7 May 2012 06:51:19 -0400,
Martin Gagnon wrote:
> Have you update server side as well?

Here is the output of fossil version on the server:

This is fossil version 1.22 [7fb59a67dc] 2012-05-05 13:53:37 UTC

Here is the output of fossil version on the client:

This is fossil version 1.22 [7fb59a67dc] 2012-05-05 13:53:37 UTC

I just issued another "fossil all rebuild" on both the client and the server to
make sure that I didn't miss anything.

I am still getting the "Error: not authorized to read" error.

First I tried just rebuilding on the client side, then trying the sync, which
didn't work, giving the same error.

Then I tried closing the repository on the client side, re-cloning under sshfs
again, changing the remote-url (where it prompted me for the password as
normally, then issuing the "fossil sync" command. Basically, it displays the
Sent: packets as it should, then it gives the "Error: not authorized to read",
then it prints the received packets.

In my testing, the sync never actually updated the repository until I gave
"nobody" expanded permissions, in which the latest revisions were updated on
the "timeline" command.

Maybe the fix is in a branch other than "trunk"? Should I try another branch
when installing from the fossil repository?

Possibly unrelated:

Maybe my issue is specific to FreeBSD? I am testing this under /bin/sh shell (I
have my shell even changed to /bin/sh at the moment on the server side to
ensure the proper behavior) because the ssh commands do not work under tcsh at
all...

Tim
_______________________________________________
fossil-users mailing list
fossil-users@lists.fossil-scm.org
http://lists.fossil-scm.org:8080/cgi-bin/mailman/listinfo/fossil-users