Message info
 
To:Waitman Gobble From:Waitman Gobble Subject:Re: [kde-freebsd] blank window form with qtcreator package Date:Wed, 28 Mar 2012 20:37:46 -0700 (PDT)
 

Waitman Gobble <uzimac@da3m0n8t3r.com> wrote ..
> Chris Rees <crees@freebsd.org> wrote ..
> > Forwarding to more appropriate list, and CCing kde@
> >
> > On 28 March 2012 15:55, Waitman Gobble <uzimac@da3m0n8t3r.com> wrote:
> > >
> > > Hi,
> > >
> > > I am having an issue with qtcreator (using pkg_add) from http://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages/Latest/
> > > running FreeBSD 10.0-CURRENT amd64/SMP
> > >
> > > When I start qtcreator a grey window form appears which is totally blank. Note
> > that the other Qt apps appear to function (ie, qtdesigner).
> > >
> > > On another machine running FreeBSD 10.0-CURRENT i386 (32bit) with the corresponding
> > Qt packages installed, qtcreator runs as expected.
> > >
> > > Pointers for troubleshooting appreciated!
> > >
> > > Thanks,
> > >
> > > --
> > > Waitman Gobble
> > > San Jose California USA
>
> other details: using Xfce4. new system build within past few days so packages/system
> should be "close-to" latest.
>
> Thank you,
>
> --
> Waitman Gobble
> San Jose California USA

Figured out the problem, I was looking at reinstalling Qt and noticed pkg_updating.. mentions issue 2012-03-13 about MIT-SHM. I didn't catch this error before using the launcher icon, but when starting qtcreator from terminal I notice the error about MIT-SHM.. searched a bit and found this page:

http://forums.freebsd.org/archive/index.php/t-29770.html

seems that
# sysctl kern.ipc.shm_allow_removed=1

fixes the problem... qtcreator then starts properly with stuff on the form (ie, not blank).

so... I suppose the explanation seems to be that
qt4-gui-4.7.4_1 is not yet available in the /Latest amd64 packages... (?) checking this out now.



Thank you,

--
Waitman Gobble
San Jose California USA