Message info
 
To:freebsd-current From:John Nielsen Subject:Re: Python won\'t build? Date:Thu, 05 Apr 2012 17:16:52 -0400
 

Quoting John Nielsen <lists@jnielsen.net>:

> On Mar 31, 2012, at 10:21 PM, John Nielsen wrote:
>
>> I updated a machine yesterday from 9-STABLE to 10-CURRENT
>> (r233631). Everything went smoothly with the update itself, but I
>> ran in to an issue with Python when rebuilding all of my installed
>> ports. Python won't build; it complains about the definition of
>> LONG_BIT. I had python27 installed but python26 does the same
>> thing. I ran "make delete-old" and "make delete-old-libs", no
>> improvement. I even built a clean chroot environment via make
>> installworld DESTDIR=..., (plus devfs and ports tree). Same problem.
>>
>> So.. is this the result of something in the FreeBSD source? Can
>> anyone else reproduce this? What should I try next?
>
> So, no chorus of "me too"s. How about a "works for me"? I'm still
> not sure if this is something peculiar to this machine or not and I
> haven't fired up a clean virtual machine on different hardware to
> verify (though I'm not far from that...).
>
> Some of my own follow up:
>
> I tried rebuilding world with sources from today, 3/9 and 2/28 and
> got the same result, so if it's a regression on the FreeBSD end it's
> been there a while (and seemingly not related to the i386/amd64/x86
> header cleanup, which led me to pick those revisions). I also tried
> setting tweaking newvers.sh to say 9.9-CURRENT and rebuilt world
> with no improvement, so if it's autotools or something else versus
> two-digit FreeBSD version problem it's something subtle.

I'm still mystified but I'm no longer having an issue. I rebuilt world
from today's sources and lo and behold, Python builds again. If anyone
knows what might have changed I'd still love to know, but otherwise I
guess I'll move on.

JN

_______________________________________________
freebsd-current@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-current
To unsubscribe, send any mail to "freebsd-current-unsubscribe@freebsd.org"