Message info
 
To:Debian Bug Tracking System From:Claudio Moretti Subject:Bug#671887: gnome-shell breaks itself via gir1.2-gconf-2.0 Date:Mon, 07 May 2012 23:00:25 +0200
 

Package: gnome-shell
Version: 3.2.2.1-4
Severity: grave
Justification: renders package unusable

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dear Maintainer,

* What led up to the situation?
gnome-shell was removed with a dist-upgrade because it requires
gir1.2-glib-2.0 which explicitly breaks gnome-shell
claudio@Chuck:~$ apt-cache depends gnome-shell
gnome-shell
[snip..]
Depends: gir1.2-glib-2.0
[snip..]
claudio@Chuck:~$ apt-cache depends gir1.2-glib-2.0
gir1.2-glib-2.0
[snip..]
Breaks: gnome-shell
[snip..]

Also, gnome-shell complains about not being able to install libcogl5,
but this seems to be impossible

root@Chuck:~# apt-get install -s libcogl5 gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnome-shell : Depends: gir1.2-clutter-1.0 but it is not going to be
installed
Depends: gir1.2-coglpango-1.0 but it is not going to be
installed
Depends: gir1.2-mutter-3.0 (>= 3.2) but it is not going
to be installed
Depends: libclutter-1.0-0 (>= 1.7.6) but it is not going
to be installed
Depends: libcogl-pango0 (>= 1.7.4) but it is not going to
be installed
Depends: libmutter0 (>= 3.2) but it is not going to be
installed
Depends: libmutter0 (< 3.3) but it is not going to be
installed
E: Unable to correct problems, you have held broken packages.


* What exactly did you do (or not do) that was effective (or
ineffective)?
When I rebooted, my system was in fallback mode and I didn't have
gnome-shell, so I tried to reinstall gnome-shell by forcing libcogl5 installation, but it didn't work

* What was the outcome of this action?
(see simulation above)

* What outcome did you expect instead?
gnome-shell installed and working


- -- System Information:
Debian Release: wheezy/sid
APT prefers unstable
APT policy: (1001, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-shell depends on:
ii dconf-gsettings-backend [gsettings-backend] 0.12.1-1
ii gconf-service 3.2.5-1
ii gir1.2-accountsservice-1.0 0.6.15-4
ii gir1.2-atk-1.0 2.4.0-2
ii gir1.2-caribou-1.0 0.4.2-2
ii gir1.2-clutter-1.0 1.10.4-3
ii gir1.2-cogl-1.0 1.10.2-3
ii gir1.2-coglpango-1.0 1.10.2-3
ii gir1.2-folks-0.6 0.6.8-2
ii gir1.2-freedesktop 1.32.1-1
ii gir1.2-gconf-2.0 3.2.5-1
ii gir1.2-gdkpixbuf-2.0 2.26.1-1
ii gir1.2-gee-1.0 0.6.4-1
ii gir1.2-gkbd-3.0 3.4.0.2-1
ii gir1.2-glib-2.0 1.32.1-1
ii gir1.2-gmenu-3.0 3.2.0.1-2
ii gir1.2-gnomebluetooth-1.0 3.2.2-1
ii gir1.2-gtk-3.0 3.4.1-2
ii gir1.2-json-1.0 0.14.2-1
ii gir1.2-mutter-3.0 3.2.2-3
ii gir1.2-networkmanager-1.0 0.9.4.0-3
ii gir1.2-pango-1.0 1.30.0-1
ii gir1.2-polkit-1.0 0.105-1
ii gir1.2-soup-2.4 2.38.1-2
ii gir1.2-telepathyglib-0.12 0.18.1-2
ii gir1.2-telepathylogger-0.2 0.4.0-1
ii gir1.2-upowerglib-1.0 0.9.16-2
ii gjs 1.32.0-2
ii gnome-bluetooth 3.2.2-1
ii gnome-icon-theme-symbolic 3.4.0-2
ii gnome-settings-daemon 3.2.2-3
ii gnome-shell-common 3.2.2.1-4
ii gsettings-desktop-schemas 3.4.1-2
ii libatk1.0-0 2.4.0-2
ii libc6 2.13-32
ii libcairo-gobject2 1.12.2-1
ii libcairo2 1.12.2-1
ii libcamel-1.2-29 3.2.2-3
ii libcanberra0 0.28-4
ii libclutter-1.0-0 1.10.4-3
ii libcogl-pango0 1.10.2-3
ii libcogl5 <none>
ii libcroco3 0.6.5-1
ii libdbus-1-3 1.5.12-1
ii libdbus-glib-1-2 0.98-1
ii libdrm2 2.4.33-1
ii libebook-1.2-12 3.2.2-3
ii libecal-1.2-10 3.2.2-3
ii libedataserver-1.2-15 3.2.2-3
ii libedataserverui-3.0-1 3.2.2-3
ii libffi5 3.0.10-3
ii libfolks25 0.6.8-2
ii libfontconfig1 2.9.0-3
ii libfreetype6 2.4.9-1
ii libgconf-2-4 3.2.5-1
ii libgdk-pixbuf2.0-0 2.26.1-1
ii libgee2 0.6.4-1
ii libgirepository-1.0-1 1.32.1-1
ii libgjs0b [libgjs0-libmozjs185-1.0] 1.32.0-2
ii libgl1-mesa-glx [libgl1] 8.0.2-2
ii libglib2.0-0 2.32.2-1
ii libgnome-desktop-3-2 3.4.1-2
ii libgnome-keyring0 3.4.1-1
ii libgnome-menu-3-0 3.2.0.1-2
ii libgstreamer0.10-0 0.10.36-1
ii libgtk-3-0 3.4.1-2
ii libical0 0.48-1
ii libjson-glib-1.0-0 0.14.2-1
ii libmozjs185-1.0 1.8.5-1.0.0+dfsg-3
ii libmutter0 3.2.2-3
ii libnm-glib4 0.9.4.0-3
ii libnm-util2 0.9.4.0-3
ii libnspr4-0d 4.9-1
ii libnss3-1d 3.13.4-1
ii libpango1.0-0 1.30.0-1
ii libpolkit-agent-1-0 0.105-1
ii libpolkit-gobject-1-0 0.105-1
ii libpulse-mainloop-glib0 1.1-3.2
ii libpulse0 1.1-3.2
ii libsoup2.4-1 2.38.1-2
ii libsqlite3-0 3.7.11-3
ii libstartup-notification0 0.12-1
ii libtelepathy-glib0 0.18.1-2
ii libtelepathy-logger2 0.4.0-1
ii libx11-6 2:1.4.99.901-2
ii libxcomposite1 1:0.4.3-2
ii libxdamage1 1:1.1.3-2
ii libxext6 2:1.3.1-2
ii libxfixes3 1:5.0-4
ii libxi6 2:1.6.0-1
ii libxml2 2.7.8.dfsg-9
ii python 2.7.2-10
ii telepathy-mission-control-5 1:5.10.1-2

Versions of packages gnome-shell recommends:
ii gnome-contacts 3.4.1-1
ii gnome-control-center 1:3.2.2-3+b1
ii gnome-session-fallback 3.4.1-1
ii gnome-themes-standard 3.4.1-2

gnome-shell suggests no packages.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk+oN+UACgkQZ0Gi6TDJB+ekPQCgquZ7qH62loEdsynxnm4SVfWh
M/MAn0r7652vVfcO75oYF2E9s0vmcW2d
=U/24
-----END PGP SIGNATURE-----



--
To UNSUBSCRIBE, email to debian-bugs-rc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org